В WordPress 4.9.7 устранены уязвимости, позволяющие удалять файлы в системе

Опубликован корректирующий выпуск системы управления web-контентом WordPress 4.9.7, в котором устранены две уязвимости, при помощи которых можно удалить произвольные файлы на сервере, насколько позволяют права доступа пользователя, под которым выполняется WordPress. Например, в ходе атаки можно удалить файл wp-config.php и инициировать процесс установки нового экземпляра WordPress при следующем открытии сайта, в ходе которой атакующий может завести новый аккаунт администратора WordPress, при помощи которого можно запустить произвольный PHP-код на сервере.

Для эксплуатации обеих уязвимостей атакующий должен иметь привилегии автора публикаций (Author) в WordPress. Уязвимости вызваны передачей в функцию unlink() имени файла, сформированного на основе переданных пользователем внешних параметров, не очищенных должным образом (например, можно указать "../../wp-config.php"). В частности данная функция вызывается для удаления эскизов изображений, при инициировании удаления приложенной к публикации картинки.

Дополнение: Информация об уязвимости была отправлена создателям WordPress ещё в ноябре прошлого года и разработчики запросили 6 месяцев на исправление. После наступления указанного срока исследователи попытались уточнить планы по исправлению и предупредили, что намерены скоро раскрыть информацию об уязвимости. Ещё спустя месяц информация об уязвимости была раскрыта. Через неделю разработчики WordPress отреагировали созданием патча и выпуском обновления 4.9.7 с устранением проблемы.

Источник: OpenNET